This project has moved and is read-only. For the latest updates, please go here.

Handbrake Hanging...but conversion appears to have completed

Jul 13, 2015 at 2:50 PM
Edited Jul 13, 2015 at 2:52 PM
I have an issue that has popped up. I noticed all of a sudden several of my conversions, have not been completing. Below is a copy of a log file for the conversion of a .mpg SageTV recording. See lines 26777 and 26778:

ERROR> --> No response from process for 300 seconds, process likely hung - killing it
ERROR> --> Process hung, killing process

The process hangs...but to me it appears that the video conversion has completed...however since it has failed...the .mp4 file is not moved so I am left with just the original .mpg file.

Does anyone have any suggestions?

Dropbox Link to .zip log file for a conversion

Dropbox Link to Profile.conf file
Jul 14, 2015 at 5:02 AM
Try this, download the latest nightly build of hte handbrake CLI and replace it in the mcebuddy handbrake directory. See if that fixes your issue.

Jul 14, 2015 at 12:46 PM
I downloaded the nightly of handbrake CLI and before leaving for work I started a couple of conversions. I will report back with the results. Its interesting - in looking at my files, some recordings are converting with no issue. In looking at my results for the past week most shows did not convert, however there was one show that converted fine, it aired two times this past week. Not sure that this means anything...but it is the only show in my recording schedule that was 30 minutes in length.

Jul 20, 2015 at 2:27 PM

I tried the nightly of hanbrake CLI and it did not perform any different. I decided to dig deeper and have solved my situation.

Here is what happened. I have a c: drive which is an SSD and MCEBuddy was installed on this drive. My D: drive is a regular hard drive used for also happens to contain the folder that I use as a temp directory for MCEBuddy. The D: drive failed. So I ordered a new one. In the mean time, I move my MCEBuddy Temp folder to a location on my NAS. For whatever reason, handbrake must have timed out while using the NAS as a temp storage location. As soon as my replacement drive arrived and I moved my temp directory back to this local hard drive everything returned to normal.

Hopefully this makes sense, thanks for your help!

Marked as answer by rboy1 on 10/15/2015 at 3:09 AM
Jul 20, 2015 at 3:29 PM
Great. Gals it worked out. How did you figure out the hard drive failed?

Jul 20, 2015 at 4:31 PM
For the D: drive failure, I did get a smart report warning in the taskbar area. My computer was also acting strange and would lockup (NTFS and other disk errors in the event log). I then pulled the power and sata cable to this drive and my PC activity returned to normal...minus some programs that were installed on that drive versus the ssd c: drive. The weird part with the NAS is that some shows converted correctly. No issues with the two 30 minute shows that were schedule to record during this time period...but on review of the MCEBuddy history log...there was at least one one-hour show that converted properly. Once the new drive was in, I reran MCEBuddy on the .mpg files that were giving me errors when the NAS was the temp drive and they all converted with no problems once the new drive was in.

As an rerun those .mpg files, I highlighted them in windows explorer and dragged them onto the MCEBuddy window...and for some reason it added two copies of each of these recordings. Any reason for this? Its no big deal, I am just curious.

Thanks again!

Jul 20, 2015 at 4:36 PM
Hmm check the history log. If adds one entry for each file and and each conversion task.
The only reason I can think is that either it matched more than one task or it added files from 2 different paths. The history will show the complete picture (button)