This project has moved and is read-only. For the latest updates, please go here.

Handling Interrupted Recordings

Dec 5, 2015 at 6:51 AM

Can you make any suggestions on how to handle interrupted recordings when using custom naming settings? I've noticed today that when I had a recording that was interrupted, MCEBuddy converted both parts but over-wrote the first conversion with the second one.

Is there a way to tell it to append a character, or at least not delete the source file when a destination filename of the same name already exists?

Logs of the event in case i'm misinterpreting what happened.!jdRmQAyJ

Thanks as always.
Dec 5, 2015 at 7:37 AM
You can enable the don't overwrite file option in the conversion task expert settings, it'll tag on an extra number at hte end of the file when it find the destination file already exists
Dec 5, 2015 at 8:14 AM
I feel a little sheepish. Not sure how I missed that setting all this time. :D

Thanks for your quick response!
Dec 6, 2015 at 7:23 AM
Edited Dec 6, 2015 at 7:38 AM
So I took the opportunity to upgrade the software to the latest nightly, and also ticked the Dont Overwrite option.

MCEBuddy is now not deleting the source file and is continually converting the same show.!LJJG3ZwI!inOV8fYDQyH4T57z__qeHIR0jgigMZPOtlAwYZE_gpk

You'll see in the link a zip with about 8 conversions of the same show.
I actually upgraded the PC from Win8.1 to Win10 during this, but it started doing several conversions while still running Win8.1

Edit: OK i found the "delete original file" in the source settings was lost in the upgrade (although the logs said "Delete Original -> True") - althoug have you changed this around a little? The main screen now says "delete manually added files".

Anyway hopefully this sorts it, although the behaviour of re-encoding the same files seems a little strange.
Dec 6, 2015 at 8:04 PM
The link is invalid

Dec 6, 2015 at 9:12 PM
Here it is on onedrive
Dec 7, 2015 at 1:16 AM
need your mcebuddy.log file

Dec 7, 2015 at 4:54 AM
Sorry. - it's in that folder.

Dec 7, 2015 at 10:16 AM
No idea why you enabled this option but that's why it's
> ReMonitor Recorded Files -> True

And it's not deleting the file because at the time when it reconverted your file the settings was:
> Monitor Delete Original -> False

Dec 9, 2015 at 5:59 AM
/me scratches head
I also have no idea how I ever set that option.. I must have ticked it literally over a year ago.. i guess it shows how well mcebuddy has worked that it hasn't caused problems till now.

Thanks again