This project has moved and is read-only. For the latest updates, please go here.

failed rename/moving of converted file (it was deleted)

Dec 5, 2015 at 4:13 PM
I have a WMC PC recording tv shows and also running MCE buddy. I just started testing out MCE buddy and I dumped two files in which converted and transferred to my NAS just fine. The next test would be to schedule a recording and see how it works without manually adding the files. I set a recording for 6am news. Later that day I checked my NAS to see if it was there and it wasn't. I checked the log to see if it even tried to convert it because the original file was still there (i have it set to archive converted files). The log shows that it did convert the file, however near the end when it goes to rename the file it says it cannot find it. The file was renamed or deleted. So it doesn't rename it, it doesn't transfer the converted file to my nas and the process ends. Can anyone help me figure out why this happened and how to solve this problem?

The log is here:
Dec 5, 2015 at 5:31 PM
Some third party program is interfering with your files (maybe an antivirus). Just before the failure cannot find file error, see these lines:

> --> Dumping complete information about the file F:\Recorded TV\MCEBUDDY Temp\working0\FOX 26 News at 6AM_KRIVDT_2015_12_03_05_58_00.mp4
2015-12-03T07:47:03 MCEBuddy.AppWrapper.Base --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffprobe.exe
2015-12-03T07:47:03 MCEBuddy.AppWrapper.Base --> Process arguments  -hide_banner -probesize 100M -analyzeduration 300M -i "F:\Recorded TV\MCEBUDDY Temp\working0\FOX 26 News at 6AM_KRIVDT_2015_12_03_05_58_00.mp4"
2015-12-03T07:47:03 MCEBuddy.AppWrapper.Base --> UI Session Admin Process : False
2015-12-03T07:47:03 MCEBuddy.AppWrapper.Base --> Setting process priority to Normal
2015-12-03T07:47:03 MCEBuddy.AppWrapper.Base --> F:\Recorded TV\MCEBUDDY Temp\working0\FOX 26 News at 6AM_KRIVDT_2015_12_03_05_58_00.mp4: Permission denied
--> Process exited with code 1

MCEBuddy tries to read the properties of the converted file and the permission is denied, it's locked by a third party program and then possibly deleted.

Dec 6, 2015 at 12:05 AM
weird. The first two files I tried manually converted, renamed and moved just fine. What would be different about an automatic conversion? I did some testing by turning off my firewall and it didn't work. Still denied it. I restarted my pc and now it is working again. What could be causing this?