This project has moved and is read-only. For the latest updates, please go here.

"Cuda driver version insufficient" Conversion errors

Jan 15, 2016 at 1:46 PM
Hi there,
I'm getting sporadic conversion errors. Most of my conversions work just fine. From my history, it looks like I am getting these errors after switching from x264 to mp4. It happens with multiple shows. The part of the log that is interesting is here:
2016-01-15T02:33:08 MCEBuddy.AppWrapper.NVidiaQuery --> CUDA Device Query (Runtime API) version (CUDART static linking)
2016-01-15T02:33:08 MCEBuddy.AppWrapper.NVidiaQuery --> cudaGetDeviceCount returned 35
2016-01-15T02:33:08 MCEBuddy.AppWrapper.NVidiaQuery --> -> CUDA driver version is insufficient for CUDA runtime version
2016-01-15T02:33:08 MCEBuddy.AppWrapper.NVidiaQuery --> Result = FAIL
WARNING> 2016-01-15T02:33:08 MCEBuddy.AppWrapper.NVidiaQuery --> Error trying process priority or setting CPU affinity to -> 0
System.InvalidOperationException: Cannot process request because the process (3212) has exited.
at System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)
at System.Diagnostics.Process.OpenProcessHandle(Int32 access)
at System.Diagnostics.Process.get_Handle()
at MCEBuddy.AppWrapper.Base.Run()
ERROR> 2016-01-15T02:33:11 MCEBuddy.Engine.ConversionJob --> Unhanded error during conversion, conversion cancelled
System.InvalidOperationException: Process was not started by this object, so requested information cannot be determined.
Any ideas?
Jonathan
Jan 15, 2016 at 2:17 PM
Please don't filter the logs, attach a link to the whole log. The issue is suspect is completely somewhere else, this is normal, the process can exit before it gets a chance to update it. However the CUDA driver is returning that it isn't available.

Jan 15, 2016 at 7:03 PM
Okay. Upload the whole log I get home tonight. My work's firewall won't let me FTP :-(

Thank,
Jonathan
Jan 16, 2016 at 3:02 PM
I guess I was more tired than I thought. Here's the link.
ftp://files.mcebuddy2x.com/upload/Discussion%20650089/
Jan 16, 2016 at 8:11 PM
Kudos to you!! First engine bug in over a year and a half. Your computer is SOOO fast that we couldn't replicate in our lab machines but we found the issue in the code thanks to your detailed log.
Thanks for reporting it, great job.

The fix will be up in today's build!



Jan 18, 2016 at 4:56 PM
Thanks rboy! So far every encode since uninstalling the stable release and installing the daily build from 1/16/16 has worked without any issue! Just wanted to give you the feedback that your fix has worked!

Thanks again!
Jonathan