This project has moved and is read-only. For the latest updates, please go here.

"Service is unavailable. Please start from Windows control panel or check engine connection."

Jan 22, 2016 at 5:31 AM
Starting getting this error a few days ago. Tried the stuff in the FAQ. Running 2.4.3. Still not working. Here is my event log. Any ideas?

Error 21-Jan-2016 9:22 PM
MCEBuddy service failed to start. Error:System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
at MCEBuddy.Engine.Core..ctor()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.ServiceModel.Description.ServiceDescription.CreateImplementation(Type serviceType)
at System.ServiceModel.Description.ServiceDescription.SetupSingleton(ServiceDescription serviceDescription, Object implementation, Boolean isWellKnown)
at System.ServiceModel.ServiceHost.CreateDescription(IDictionary`2& implementedContracts)
at System.ServiceModel.ServiceHostBase.InitializeDescription(UriSchemeKeyedCollection baseAddresses)
at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)
at MCEBuddy.Service.ServiceModule.OnStart(String[] args)
Jan 22, 2016 at 6:27 AM
See the FAQ's on Common Issues and Installation Issues. You have a corrupted filesystem, do a clean install

Jan 22, 2016 at 10:46 PM
I uninstalled MCEBuddy and reinstalled yesterday, did not work. How do I do a "clean" install?
Jan 23, 2016 at 2:18 PM
See the documentation installation issue page