This project has moved and is read-only. For the latest updates, please go here.

Service unavailable

Jan 27, 2016 at 3:24 PM
I just installed 2.4.4 on my Win10 desktop
The service shows "running" in Windows Services
I tried restarting the service, stopping it and starting it, and restarting mcebuddy several times.
Every time mcebuddy gui comes up and says service unavailable please try to start from control panel, etc.
I can't seem to get the gui running with the service.
Any help?
Jan 27, 2016 at 6:40 PM
UPDATE: I'm going to try a "clean install" per the "installation issues" documentation page, and see if that helps. I'll report back if still no luck.
Jan 27, 2016 at 8:30 PM
Also see the windows logs. It's very possible you have a corrupted disk which causing windows to terminate the process. See the recently closed tickets. Disk corruption on installation or on the video files you're using. If the source file is corrupted it causes windows to terminate mcebuddy

Marked as answer by rboy1 on 2/3/2016 at 11:06 PM
Jan 28, 2016 at 12:14 AM
Edited Jan 28, 2016 at 12:16 AM
Thanks for the advice.
I did a clean install (per your instructions on the doc's page) and everything went well on install. The service is running the GUI starts fine, I'm able to stop the service and edit settings, etc. I re-made my personal conversion tasks without too much trouble.
However, now MCEBuddy won't initiate any conversions, even though there are a couple of recordings in the Monitored locations.
The old MCEBuddy had converted these recordings, but I deleted the conversions in hopes of improving my custom tasks.
Given that I did a "clean install" I thought that there couldn't be any logs anywhere that would tell MCEBuddy that it had already converted these files. Might I have missed something? Is there a log or history file I need to delete, even after a "clean install"
EDIT: I just checked the history and logs links from the MCEBuddy GUI. Both are empty (well the logs folder has one log from a few minutes ago when I started up the new install, but that's it.)
Jan 28, 2016 at 12:25 AM
Clear the history. Click on the history link

Jan 28, 2016 at 1:14 AM
The history table was (and still is) empty. Clicking clear history didn't do anything.
I opened the mcebuddy.log file, and it looks like MCEBuddy is indeed scanning the files in the monitored directory (good - I thought maybe it wasn't able to log in to the network share). I don't really understand what all is in the log file, but it's definitely scanning the recordings. But then nothing happens. It doesn't initiate any conversions/ecodings.
Jan 28, 2016 at 9:17 AM
It's a network share check your time stamps on your network drive, likely out of sync. Disable the minimum age in the monitor task if you can't correct your timestamps.

Jan 28, 2016 at 6:49 PM
Time stamps of the recordings? They are correct. All from several days ago. What would they be out of sync with?
I disabled the minimum age anyway, and nothing happened. Any other suggestions?
MCEBuddy is still just sitting there, won't initiate any conversions.
Jan 28, 2016 at 6:55 PM
upload your mcebuddy.log file to the server.

Jan 28, 2016 at 7:05 PM
Jan 28, 2016 at 8:23 PM
Did you go through the log file?

It's clearly saying that your network show filters didn't match the file metadata.

Jan 28, 2016 at 9:02 PM
Well, I'm not an expert in reading these log files, but yes, I saw that there were warnings or errors about the filters and the metadata. However, I thought those were correct: there are some shows in the monitored folder I don't want converted with this task (e.g. PBS shows with no commercials) so I put a filter to exclude channels KQED and KRCB. That would exclude recordings of the shows named Nova and Nature. But all the other recordings (movies and X-files) should get converted. Why are they not getting converted? I didn't put any filters in place to stop them.
Thanks for continuing to help me figure this out....
Jan 28, 2016 at 9:41 PM
Edited Jan 28, 2016 at 9:48 PM
I think I've found the problem!
My filter was the following:
I did not realize that I also needed to include a * by itself to tell it to go ahead and process everything else. Now, with my filter like this: * ;~KQED*;~KRCB*
MCEBuddy seems to be working normally again.
Jan 29, 2016 at 1:18 AM
Hmm okay maybe in the next build I think we should put a sanity check and if the user has forgotten to include a "\*" MCEBuddy should probably include it for them

Jan 29, 2016 at 6:44 AM
Yeah, I guess I forgot. I've used these filter rules before, but starting from scratch this time I forgot. If you leave it blank it records everything, so my logic was just tell it the few channels I -don't- want. :)
Jan 29, 2016 at 4:10 PM
Fixed with today's build. Give it a whirl and let us know if it works. (use your same don't match rules without any matching rules and it should work)

Marked as answer by rboy1 on 2/3/2016 at 11:05 PM
Jan 29, 2016 at 4:51 PM
I'll update this weekend and give it a try. Thanks for your help.
Feb 4, 2016 at 7:06 AM
Guessing it's working now.