This project has moved. For the latest updates, please go here.

Moving converted files to NAS drive only works sometimes

Sep 26, 2016 at 11:13 PM
Most of the time conversions run and the files end up on my NAS like I want. I've read thru a few of the threads on issues with remote or mapped drives, and I know my issue isn't with login, because most of the time it does work. It's possible that at the time of conversion, the NAS is unreachable, or offline, that does happen sometimes. I'm less concerned with eliminating connection issues, (though improvements there are welcome), but more concerned with losing the whole conversion when it can't find the NAS. I thought I had it setup so that if it can't find the NAS, it would simply leave the converted file somewhere, so I could manually move it, though I can't figure out how to specify where that somewhere is. It looks like MCEBuddy is leaving the files in the working folder, then either overwriting the file with next job, or does it automatically delete working folder when done?

Here's an excerpt from the log file for a conversion that did not move. Not sure how to upload whole log, but I think this has the relevant points:

ERROR> --> Unable to move file C:\Program Files\MCEBuddy2x\working0\S01E01-Pilot.mp4 to \VAULT\video\TV Shows
Error :System.IO.IOException: The user name or password is incorrect.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)
at MCEBuddy.Util.FileIO.MoveAndInheritPermissions(String source, String destination)
at MCEBuddy.Engine.ConversionJob.MoveConvertedFile(String subDestinationPath, Log jobLog)
INFORMATION> 2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Fallback to source path
WARNING> --> Fallback to Source Path is enabled, trying to move directory to source path -> C:\Program Files\MCEBuddy2x\working0
INFORMATION> 2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Moving converted file C:\Program Files\MCEBuddy2x\working0\S01E01-Pilot.mp4 to C:\Program Files\MCEBuddy2x\working0\This Is Us\Season 01\S01E01-Pilot.mp4
INFORMATION> 2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Running custom commands
2016-09-24T23:58:30 MCEBuddy.Transcode.CustomCommand --> Custom command parameters read ->
PostCustomCommandPath =
PostCustomCommandParameters =
PostCustomCommandHangPeriod = 300
PostCustomCommandCritical = False
PostCustomCommandUISession = False
PostCustomCommandShowWindow = True
PostCustomCommandExitCodeCheck = False
INFORMATION> 2016-09-24T23:58:30 MCEBuddy.Transcode.CustomCommand --> No custom commands found
2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Finished end of conversion custom command, file size [KB] 569,715.00
INFORMATION> 2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Success - All done!
INFORMATION> 2016-09-24T23:58:31 MCEBuddy.Engine.ConversionJob -->


As I said, I know username and pwd are correct, because it moved other files, and I haven't changed settings. Is there a way to designate a place for moving the file if NAS isn't found? I searched whole HD for the file "S01E01-Pilot.mp4" but it's nowhere to be found. I thought having
NFORMATION> 2016-09-24T23:58:30 MCEBuddy.Engine.ConversionJob --> Fallback to source path
WARNING> --> Fallback to Source Path is enabled, trying to move directory to source path ->
enabled would move the file to the source where it found the original .ts, but it tried to move it back to C:\Program Files\MCEBuddy2x\working0 instead.

Any help is appreciated!
Thanks!
Coordinator
Sep 26, 2016 at 11:30 PM
That's just windows saying it can't authenticate, it's denying access. I guess somewhere along the way some other software is changing the authentication (or disconnecting it and reauthenticating it).

Will check on the fallback to source path.

Coordinator
Sep 26, 2016 at 11:44 PM
The fallback is working fine here. Can you upload your conversion log file, it'll show what's going on.

Sep 26, 2016 at 11:56 PM
How do i upload a file? I assume you don't want me to paste all the text here? Do I have to host the file somewhere and link it?
Coordinator
Sep 27, 2016 at 12:34 AM
See the read me before posting sticky thread

Sep 27, 2016 at 12:45 AM
DOH! I suppose I should have figured that out on my own! Sorry.

Anyway, put 3 files in a folder "discussion 658273", return to orange county, worked as it's supposed to. the other 2 did not. Figured more examples might be helpful. Thanks for the quick responses!
Coordinator
Sep 27, 2016 at 5:50 AM
so before we continue any further please update to the latest build, you're on a build that over a year old, it may just fix your issue